Railsの個人プロジェクトにWebpackerとVueを入れてVueに移行していくぞーと思っています。EmacsっだとVueがつらそうなので眠っていたRubyMineを使ってみようと起動したのですが、JSのimport構文に警告がでていました。

import declarations are not supported by current javascript version

RubyMineが実行するわけではないので直接は問題ないのですが、いちいちこれが出るのも鬱陶しいのできちんと対応します。

ソースコードから変更するには、警告箇所の電球マークを押すと出てくる提案メニューから「Change JavaScript language version to ECMAScript 6」を選択します。

しばらくすると構文解析が終わって波線が消えると思います。

設定メニューから変える場合は「Languages & Frameworks」の「JavaScript」から「JavaScript language version」を「ECMAScript 6」を選択して保存すればOK。